The Distance view shows a matrix (i.e., table) of numbers representing distances computed for each pair of sequences for the selected aligned block. Sequence distances are used as input in creating the phylogenetic tree shown in the Tree view. Selections within the Distance view are synchronized with other views in MegAlign Pro. Similarly, selections made elsewhere will be highlighted simultaneously in the Distance view.

The Distance view is only accessible after you have performed a multiple alignment, and becomes inaccessible again if you unalign the sequences. After performing an alignment, you can access the view by clicking on the Distance tab.

  • Larger numbers correspond to greater differences between sequences. Uncorrected distances are always ≤1.0. However, the Kimura and Tamura-Nei values can exceed 1.0 because they reflect the inferred actual number of nucleotide substitutions or amino acid replacements per site, not the observed distance.
  • The upper and lower triangles of the matrix are reflections of one other and contain the same information.
  • No numbers appear on the diagonal, since a sequence cannot differ from itself.
  • In certain situations, it may not be possible to calculate distances for every pair of aligned sequences, in which case “NA” is displayed. In other cases, “NA” may be an artifact of the computational algorithm; for example, an attempt to calculate the log of a negative number.
  • When the divergence between a pair of sequence is greater than about 0.75, it may not be possible to calculate a value for corrected distance using the Kimura and Tamura-Nei metrics.


Information bar:

The blue/gray bar at the top of the view shows information pertaining to the current selection.

Selection Example Information displayed
Nothing The distance calculation metric (see Distance metric options).
One sequence or a row/column header (letter) The name of the sequence and length in bp.
One table cell The number of sequences involved in the cell and their alignment status.


Tasks pertaining to the Distance view:

Task How to…
Task How To
Customize the look of the Distance view Use the Distance section of the Style panel.
Change the method and/or parameters used to generate the distance table Click the Change Analysis Parameters tool ( ). This opens the Analysis Options dialog where you can specify the Metric and Gap Treatment, the first two parameters from the Distance section of the Style panel.

Display a tool tip with the name of the sequence corresponding to a cell Hover over any row/column header or any cell on the diagonal of the matrix.

Display a tool tip with the the two sequence names and the distance between them Hover over a distance cell in the table that is not on the diagonal. For projects using Pairwise gap removal (see Distance section), the tool tip also contains the number of residues considered for that pair.
Select all cells in the table Choose Distance > Table > Select All.
Use editing commands with the Distance table Choose Distance > Table > Copy (Select All, Rename, Rename with Fields).
Freeze scrolling Choose Distance > Table > Freeze Scrolling Region. In a large table, this command allows you to compare rows near the top with those further down.

Export data from the view Click the Export Data tool (), a shortcut to the File > Export Data subcommands. See Export data to a file.
Add a “details” header to the view Click the Show Quick Details tool ().



The header contains a subset of the following information:

  • Block – (multi-block Mauve alignments only) The color of the alignment block currently selected in the Overview.

  • Metric – The Metric (calculation method) specified in the Distance section of the Style panel.

  • Sequences – The number of sequences in the alignment or in the active block.

  • Global/Pairwise gap removal – The gap treatment specified in the Distance section.

  • Residues considered – Total length of alignment minus all columns containing even a single gap. This field shows both the minimum and maximum number of residues considered, if they differ.
Detach the Distance view Use the Detach View tool () or choose View > Distance > Detach. See Hide, show or resize items in the MegAlign Pro window.
Show the active view in full-screen mode Use the View > Full Screen command or the the Full screen tool at the bottom right corner of the view.
Exit full screen mode Press the Esc key or use the Exit full screen tool ) at the bottom of the full-screen view.

Need more help with this?
Contact DNASTAR

Thanks for your feedback.