MegAlign Pro lets you create and display one or more phylogenetic trees for a multiple alignment. The trees can use different algorithms, or the same algorithm with different settings.

To generate a new tree:

  1. Add sequences and perform a multiple alignment.
  1. Open the Tree view and choose one of the two available tree-building algorithms for the initial tree.



    • Neighbor joining: BIONJ uses the BIONJ algorithm (Gascuel, 1997, a variant of the Neighbor-Joining algorithm (Saito and Nei, 1987) that was used in classic MegAlign.

  • Maximum likelihood: RAxML was developed by Stamatakis (2014). Comprehensive information about options associated with this algorithm can be found in the RAxML Manual (PDF).
  1. A popup window appears. Customize settings based on the algorithm you chose.

    • If you chose Neighbor joining: BIONJ:



      • Type in a new Name for the tree or keep the default name of Tree <number>.

      • If you change your mind and want to use the other algorithm, choose it from the Using drop-down menu.

      • Press OK to generate the tree.

    • If you chose Maximum Likelihood: RAxML:



      • Type in a new Name for the tree or keep the default name of Tree <number>.

      • If you change your mind and want to use the other algorithm, choose it from the Using drop-down menu.

      • To add a bootstrapping step to the calculation, place a checkmark next to Bootstrap analysis; if you do so, another option appears. Type in the number of Iterations or keep the default value of 100.

      • Keep the default Seed value, type in a new integer, or select Choose > Random to enter a random value in the box.

      • Enter the desired number of Threads. The default value is 2.

      • Press OK to generate the tree.
  1. (optional) Use the Style panel’s Tree section to customize the tree as desired.


To create an additional tree:

When you open the Tree view, the Trees section of the Explorer panel opens by default. To add another tree, press the green plus-sign tool () to the right of the table. Initially, the Neighbor joining: BIONJ popup appears. To switch to Maximum Likelihood: RAxML, use the Using drop-down menu. Customize other options as described above. Press OK to create the new tree.


To control which tree is currently displayed:

There are three methods for choosing which tree is displayed in the Tree view.

  • View > Tree commands – Use *View > Tree > (Tree name) to make that tree active.
  • Explorer panel – The Trees section of the Explorer panel contains a table listing the name of each tree, the method used to create it, and the time the tree was built. To make a particular tree active, click its row in the table. In the example below, three trees are available and their names are: Tree (the default tree), Tree 1 and Tree 2.

  • Tree view tab – The Tree view tab shows the number of available trees as follows: (Number of trees) Tree*. The trees themselves are numbered as specified during their creation (see steps above). In the example below, four trees are available, and their names are: Tree (the default tree), Tree 3, Tree 5 and Tree 7.


To import a Newick-format tree file:

MegAlign Pro can open Newick trees with .newick, .txt or .tree extensions.

  1. Make any MegAlign Pro project tab active, or open a new, blank project. Trees cannot be opened from within the Welcome screen
  1. Choose File > Add Trees.
  1. Select one or more Newick tree files and choose Open. Each tree is added as a named tree in the Tree view tab and the Explorer panel, as described above. The tree name is the same as the file name.
  1. (optional) If desired, repeat Step 2 to add additional trees.

Need more help with this?
Contact DNASTAR

Thanks for your feedback.