The Tree view shows evolutionary relationships estimated from the multiple sequence alignment, and is calculated using the current tree-building algorithm and settings, and the currently-selected Distance metric.

The Tree view is only accessible after you have performed a multiple alignment, and becomes inaccessible again if you unalign the sequences. After performing an alignment, you can access the view by choosing View > Tree > Tree command or by clicking on the Tree tab, the dark blue part of the image below.

The Tree view initially displays the following graphic, prompting you to choose a tree-building algorithm.

For detailed information on algorithms and their customizable settings, see Phylogenetic Trees. The same topic describes how to create and format additional trees and how to control which tree is displayed.

The following video is a brief overview of the Tree view as it existed in MegAlign Pro 12.0. Many updates have been made to the software since then, but it still provides some useful information.

Some information about the view:

  • Selections within the Tree view are synchronized with other views in MegAlign Pro. Similarly, selections made elsewhere will be highlighted simultaneously in the Tree view.
  • Branch lengths are displayed, by default, and a distance scale appears at the bottom left of the image. Phylogenetic trees are considered to be reflections of the evolutionary relationships between the aligned sequences. Due to the nature of the tree-building algorithm, note that the sum of branch lengths between any pair of sequences is not expected to equal the pairwise distance reported in the Distance view. This is because the computed branch lengths are conditioned by the relationships to other sequences represented on the tree.
  • Changes made to the alignment (e.g., realigning with a different method, or with additional sequences) or to the distance metric cause the tree to be recalculated.
  • In certain situations, it may not be possible to calculate distances for every pair of aligned sequences. In these cases, sub-clusters of related sequences may be shown together on separate trees, or listed together as a single node. See Distance view for more information.
  • Due to the difference in clustering algorithms, trees built in MegAlign (discontinued in 2019) and MegAlign Pro may appear different. In addition, trees built in MegAlign are rooted, whereas trees built in MegAlign Pro are always unrooted, regardless of the method used for the alignment. The presence or absence of “roots” can cause a discrepancy in the vertical ordering of sequences between the two applications.


Information bar:

The blue/gray bar at the top of the view starts on the left end showing the color of the Block (multi-block Mauve alignments only). The rest of the information bar consists of information pertaining to the current selection.

Selection Example Information displayed
Nothing The name of the tree-building algorithm.
One sequence The name of the sequence and length in bp.
More than one sequence The number of sequences selected and their alignment status.


Tasks pertaining to the Tree view:

Task How To
Search for a sequence by name Click the Search tool () on the right of the header area to open a search area. See Search for a sequence using a text query for details.
Order branches or sequences Use the commands in the Tree menu or click the Sort sequences tool () on the right of the header area to open a menu with options for changing the layout of the tree. A common reason to use these commands is when preparing the tree image for publication. You may wish to order the tree to create a pleasing image or to draw the viewer’s focus to a certain spot, or to allow for easier comparison. Note that in the command names, “ascending” and “descending” are arbitrary terms referring to the display structure of the tree. “Ascending” tends to form a diagonal from the upper-left to lower right while “descending” tends to form a diagonal from lower-left to upper-right. Commands include:

  • Order Ascending/Descending By > Default Order – Sorts in descending order by depth (i.e. by the sum of the branch lengths).

  • Order Ascending/Descending By > Depth – Sorts in ascending/descending order by the sum of the branch lengths. Depth measures branching; the children of a subtree are sorted by the maximum number of branches to a leaf.

  • Order Ascending/Descending By > Distance – Sorts in ascending/descending order by the distance between samples in the dataset. The children of a subtree are sorted by the maximum distance (i.e. length in one dimension) from the subtree node to a leaf.

  • Order Sequences Like Tree – To force the other views to reorder their sequences to agree with the order in the Tree view.
View current tree algorithm and name the tree Click the View settings tool (). This opens the View Settings dialog where you can see the method employed to draw the tree and type in a new Name if desired.

Change the appearance of the tree Use View > Style > Tree to open the Tree section of the Style panel. Alternatively, click the Show Style tool () to add a row below the current header that replicates this section. In either case, see the Tree section topic for information on changing settings.



To minimize the row, click the tool again or use the Collapse tool (inverted ‘v’) on the right of the row.
Save an image of the current tree Use the Take snapshot tool (). In the save dialog, choose whether to save the image as a PNG, JPG, PDF, or editable PowerPoint document (.pptx).
Change the method and/or parameters used to generate the tree Click the Compute Phylogeny tool (). This is a shortcut to the Tree > Compute Phylogeny command and allows you to change the tree calculation algorithm and related parameters. For detailed information, see Phylogenetic Trees.
Redraw the tree according to the default settings Use Tree > Reset View of Phylogenetic Tree or Ctrl/Cmd+Shift+R.
Export data from the view Click the Export Data tool (), a shortcut to the File > Export Data subcommands. See Export data to a file.
Export an image of the view Click the Export Image tool (), a shortcut to the File > Export Image > (Tree Name). See Export an image of the view for details about export options.
Print the view Click the Print tool (). See Print Images for details.
Select one or more items in the tree Double-click on a sequence to select it. To select all sequences in a branch (i.e., a clade), click the vertical bar for that branch. Click any horizontal bar to select every sequence in the tree. Any selection you make is synchronized across all MegAlign Pro views. To compare selected sequences, go to the Sequences view and use drag and drop to move the selected (highlighted) sequences to any location to view them side-by-side.
Add a “details” header to the view Click the Show Quick Details tool ().

The header contains a subset of the following information:

  • Block – (multi-block Mauve alignments only) The color of the alignment block currently selected in the Overview.

  • Clustering – The clustering method used.

  • Metric – The distance metric (calculation method) specified using Distance > Parameters.

  • Sequences – Number of sequences in the alignment or in the active block.

  • Global/Pairwise gap removal – The gap treatment specified in the the Distance section of the Style panel.

  • Residues considered – Total length of alignment minus all columns containing even a single gap. This field shows both the minimum and maximum number of residues considered, if they differ.

Need more help with this?
Contact DNASTAR

Thanks for your feedback.