Try it! – Map features

Features » Try it! – Map features

Both MegAlign Pro and SeqNinja allow you to copy a single annotation, or all annotations from a source sequence to a target sequence. During the process, you may optionally filter features so as to include or exclude specific gene types. In this tutorial, you will…

Try it! – Perform a Clustal Omega alignment

Perform a Multiple Alignment » Try it! – Perform a Clustal Omega alignment

In this tutorial, you will align alcohol dehydrogenase sequences from five animal species using the Clustal Omega algorithm. Begin with Part A: Add and align sequences.

Try it! – Perform a MUSCLE alignment with multi-segment sequences

Perform a Multiple Alignment » Try it! – Perform a MUSCLE alignment with multi-segment sequences

Sequences that consist of more than one chromosome, contig, or fragment are called multi-segment files. Suppose you want to string together the consensus sequences from all the contigs in an assembly, or chromosomes in a genome, or exons in a gene, etc. If you enter…

Try it! – Add and align multi-segment sequences

Sequences » Add multi-segment sequences to a project » Try it! – Add and align multi-segment sequences

The following video tutorial describes how to add multi-segment sequences and then align them using the MUSCLE multiple alignment algorithm. The data used is available for free download here: Windows data / Macintosh data.

Try it! – Perform a genomic alignment with Mauve

Perform a Multiple Alignment » Try it! – Perform a genomic alignment with Mauve

In this tutorial, you will be adding six nucleotide sequences to MegAlign Pro using drag & drop, and then aligning them with the Progressive Mauve algorithm. Drag and drop is a feature available in all Lasergene applications, and is useful for entering multiple…

Download and extract tutorial data

Appendix » Download and extract tutorial data

Before beginning a tutorial (“Try it!” topic), you may need to download data from the DNASTAR website: Go to the DNASTAR Training page. Click on MegAlign Pro to expand its section. To the right of Written Tutorial Data, click the name of your…

Welcome to MegAlign Pro

Welcome to MegAlign Pro

MegAlign Pro is Lasergene’s application for generating multiple and pairwise alignments of protein and/or nucleic acid sequences using your choice of alignment methods. Easily navigate between synchronized views with a click of a button, and rearrange views and…

Export a tree to a tree viewer

Export » Export a tree to a tree viewer

As described in Export data to a file, Phylogenetic trees can be exported in Newick (.newick) or Nexus (.nex, .nxs) formats using File > Export Data > Tree. The saved files can be opened by many free and commercial evolutionary biology software programs. The…

Part B: Replace a sequence in the Overview and view the phylogenetic tree

Perform a Multiple Alignment » Try it! – Perform a MUSCLE alignment with multi-segment sequences » Part B: Replace a sequence in the Overview and view the phylogenetic tree

In the Overview, look for the longest segment and the longest gap region (shown in gray) in each sequence. Note that both of these are located on the left for "Rat," and on the right for all the other groups. These clues indicate that the segments for "Rat" were likely…

Part A: Add and align multi-segment files

Perform a Multiple Alignment » Try it! – Perform a MUSCLE alignment with multi-segment sequences » Part A: Add and align multi-segment files

Download and extract the tutorial data. If a MegAlign Pro project is already open, choose File > New Alignment Project. Otherwise, launch MegAlign Pro. Choose File > Add Sequences End-to-end, or click on the Add sequences end-to-end in project…

Export data to a file

Export » Export data to a file

Several commands in the File menu allow you to export alignments, distance matrices and phylogenetic trees, as well as aligned sequences and the consensus sequence. Unless you wish to export all sequences in the project, you must first make a selection. Item to…

Troubleshoot the error “A different version is running”

Appendix » Troubleshoot the error “A different version is running”

If you receive the error “A different version of Lasergene is running” when you try to launch a Lasergene application, but another version of Lasergene actually isn’t running, there may be a lingering .state file from another version that needs to be…

Notes regarding multiple alignments

Perform a Multiple Alignment » Perform an initial multiple alignment » Notes regarding multiple alignments

When performing a multiple alignment, take the following tips into consideration. Sequence order matters: The order in which sequences appear in the Overview and Sequences view may affect the results of the multiple sequence alignment. If you are not satisfied with…

Part D: Change metrics and rendering in the Distance view

Perform a Multiple Alignment » Try it! – Perform a Clustal Omega alignment » Part D: Change metrics and rendering in the Distance view

The Distance view shows a matrix (i.e., table) of numbers representing distances between each pair of sequences. Sequence distances are used as input in creating the Tree view, which you will explore in Part E. Selections within this view are synchronized with other…

Part E: Change the appearance of the Tree view

Perform a Multiple Alignment » Try it! – Perform a Clustal Omega alignment » Part E: Change the appearance of the Tree view

The Tree view shows evolutionary relationships predicted from the multiple sequence alignment, and is built using the BioNJ algorithm (Gascuel, 1997), a variant of the Neighbor-Joining algorithm (Saito and Nei, 1987). Selections within this view are synchronized…

Using the Overview as a sequence navigation tool

MegAlign Pro Interface » Views » Overview » Using the Overview as a sequence navigation tool

The light blue vertical column in the Overview is a “viewport” showing the region currently being displayed in the Sequences view. There are a number of methods—all performed within the Overview—for using the slider to navigate to a particular region in the…

Multiple alignment methods and options

Perform a Multiple Alignment » Multiple alignment methods and options

MegAlign Pro offers both gene-level and genome-level multiple alignment algorithms. Gene-level alignment of either protein or nucleotide sequences: In general, the three gene-level aligners have higher accuracy than the genome-level (Mauve) aligner. They offer…

Clean cached files on startup

Appendix » Clean cached files on startup

Prior to the Lasergene 14.0 release, the default MegAlign Pro startup ran a “-clean” option. This option automatically removed some cached files on application restart. The “-clean” option is no longer executed at each startup. However, if you are a Windows…

Favorites section

MegAlign Pro Interface » Panels » Places panel » Favorites section

The Favorites section is similar to the bookmarks folder for a web browser. It contains a list of previously-visited locations that you have decided you may wish to visit again. To access the Favorites section: Click on the Places panel expand bar entitled…

Places panel

MegAlign Pro Interface » Panels » Places panel

The Places panel lets you quickly navigate to a sequence location or range that you have visited before. The following video shows to bookmark favorite locations using the Places panel: To open the Places panel: Click on the Places tab (). If the panel is not…

Rename sequences manually

Sequences » Rename sequences manually

To manually rename a selected sequence: Select a single sequence name from any MegAlign Pro view, then right-click on it and choose Rename. Alternatively, select the sequence name and choose Edit > Rename. The Choose Label dialog opens with the Display…

Features panel

MegAlign Pro Interface » Panels » Features panel

The Features panel lets you specify which feature types should be visible in the Overview and the Sequences view once a sequence has been expanded. To open the Features panel: Click on the Features tab (). If the panel is not already visible, reveal it using any of…

Part D: View the phylogenetic tree

Perform a Multiple Alignment » Try it! – Perform a genomic alignment with Mauve » Part D: View the phylogenetic tree

*Note: The images in this section show examples of how the trees might appear. Your trees may have different arrangements or different branch lengths from the ones shown. The current names of each sequence originated from the accession numbers that were embedded in…

Part C: Change sequence names and rendering in the Sequences view

Perform a Multiple Alignment » Try it! – Perform a Clustal Omega alignment » Part C: Change sequence names and rendering in the Sequences view

In Part B, you looked at the Sequences view while learning the function of the "viewport." You will now explore the Sequences view in more depth. The Sequences view displays entered sequences and aligned sequences. Sequences selected in this view are simultaneously…

Numeric tracks

Tracks » Numeric tracks

A numeric track displays a plot of values along one or more sequences in the project. To display numeric tracks: The visibility of numeric tracks in the Sequences view is dependent on: The origin of the project. For example, the Model ‘n’ Cα Distances…

Part B: Map a single feature

Features » Try it! – Map features » Part B: Map a single feature

In this part of the tutorial, you will map a single selected feature from the source sequence to the target sequence. In order to choose the appropriate mapping command, you will need to know where the source and target sequences appear in relation to one another in…

Part C: View a genomic alignment in the Overview

Perform a Multiple Alignment » Try it! – Perform a genomic alignment with Mauve » Part C: View a genomic alignment in the Overview

Once the alignment has finished, notice how the Overview has changed in response to the parameter change, including changes to the colors of the blocks, and differences in which blocks are hanging below the line (i.e., on the opposite strand). Locate the…

Style panel

MegAlign Pro Interface » Panels » Style panel

The Style panel has expandable sections with options affecting the Overview, Sequences, Distance and Tree views, as well as multiple and pairwise alignments. To open the Style panel: Click on the Style tab (). If the panel is not already visible, reveal it using any…

Search

Search

To go to a specified position: Choose Edit > Go To (Pairwise) Position, use Ctrl/Cmd+J. If the project contains only aligned or only unaligned sequences, type in a number and click OK. If the project contains a mixture of aligned and unaligned sequences,…

Part F: Export the annotated target sequence

Features » Try it! – Map features » Part F: Export the annotated target sequence

In MegAlign Pro, hover over any target sequence annotation to read the entry. Verify that the sample entry matches your search criteria by checking the following: Is the feature a CDS? Does its original note contain the letters “RB”? Also observe…

Copy, Paste and Delete

Copy, Paste and Delete

In many cases, once you have selected text, data, sequences or subsequences, you can copy the information to the clipboard. *Note: Copy functions are limited by application memory and operating system buffer size. Therefore, for very long sequences or subsequences,…

Add ungapped sequences to a project

Sequences » Add ungapped sequences to a project

To add standard (ungapped) sequences, or additional sequences, to an existing project: You can add standard DNA, RNA or protein sequences from a wide variety of file types, including SeqNinja .star files. (See Advantages of using SeqNinja files). Choose File > Add…

Advantages of using SeqNinja files

Sequences » Add ungapped sequences to a project » Advantages of using SeqNinja files

SeqNinja is DNASTAR’s tool for advanced and batch editing of genome sequences and features. SeqNinja allows you to convert file formats, batch edit and export features, merge and split sequence data, and transfer features between genome versions, automating the…

Add multi-segment sequences to a project

Sequences » Add multi-segment sequences to a project

Sequences that consist of more than one chromosome, contig, or fragment are called multi-segment sequences. By entering a group of sequences into MegAlign Pro using a special command, the entire data set will be concatenated end-to-end and treated as a…

Retain custom names during export

Export » Retain custom names during export

After using File > Rename or File > Rename with Fields, the custom names are only exported as part of the sequence data in certain cases. Raw data sequences imported into MegAlign are never modified in any way, and always retain their original names. The following…

Details panel

MegAlign Pro Interface » Panels » Details panel

The Details panel shows details of the application, selection or project. To open the Details panel: This panel is represented by a blue “information” icon (). If the panel is not already visible, reveal it using any of the following methods: Choose View >…

Part B: Navigate using the Overview

Perform a Multiple Alignment » Try it! – Perform a Clustal Omega alignment » Part B: Navigate using the Overview

Observe that the sequence blocks in the Overview are now the same lengths. Sequence gaps are represented by gray coloring within the blocks. The light blue vertical column shown at the left of the green blocks, above, is a "viewport" showing which region is…

Change the appearance of a view

MegAlign Pro Interface » Views » Change the appearance of a view

The following table shows methods for changing the appearance of one or more views: Task How to… To show a view Use View > Show Document View > (View Name). To split the project into two sections that are arranged as a…

Distance view

MegAlign Pro Interface » Views » Distance view

The Distance view shows a matrix (i.e., table) of numbers representing distances computed for each pair of sequences for the selected aligned block. Sequence distances are used as input in creating the phylogenetic tree shown in the Tree view. Selections within the…

Substitution matrices

Perform a Pairwise Alignment » Substitution matrices

A substitution matrix describes the rate at which a nucleotide or amino acid changes to another nucleotide or amino acid over time. When performing a pairwise alignment, you can specify the desired substitution matrix in the (Pairwise) Alignment Options…

Features screen

Features » Map features (copy features to another sequence) » Features screen

The Features screen is the first wizard screen of the Map Features dialog, and allows you to choose the features you want to include or exclude in the mapping. *Note: This dialog is optional, and you may click Next, if desired, to skip to the next screen. However,…

Merge two existing alignments (“Profile alignment”)

Perform a Multiple Alignment » Modify a multiple alignment » Merge two existing alignments (“Profile alignment”)

To merge two existing alignments: A “profile alignment” occurs when you merge a MegAlign Pro alignment (.msa) that was saved earlier with the current project. Profile alignments merge two existing multiple alignments without removing any of the existing gaps.…

Create or Open a Project

Create or Open a Project

To open an existing MegAlign Pro project (.msa): Use the File > Open command, select the Open a file tool (), or press Ctrl/Cmd+O. Once a project is open in MegAlign Pro, you can open additional files using the same command. If you moved or renamed any of the…

Make a Selection

Make a Selection

Depending on the view, you can select one or more sequences, any portion of a sequence, or a specific portion of sequence corresponding to a feature. The active selection is highlighted in light blue. The selection can then be copied to the clipboard, copied in a…

Features tracks

Tracks » Features tracks

To display sequence features: The visibility of feature (annotation) tracks in the Overview, Sequences view and Pairwise view is dependent on: Whether or not tracks are visible in those views. To display hidden tracks, click on the plus sign next to the sequence of…

Options screen

Features » Map features (copy features to another sequence) » Options screen

The Options screen is the second wizard screen of the Map Features dialog, and lets you specify mapping options. Mapping – Use the text boxes or sliders to specify percent cutoffs for: Minimum feature coverage, where: Minimum sequence…

Hide, show, move, or resize items in the MegAlign Pro window

MegAlign Pro Interface » Hide, show, move, or resize items in the MegAlign Pro window

Controls for MegAlign Pro’s docking area, panels and expand bars are described in the following table. Not all options in the table are applicable to every item. Task “How To” To show or open a hidden item Use the associated View menu…

Export an image of the view

Export » Export an image of the view

To export an image of a view : Choose File > Export Image > (View Name). Specify the file name and choose the export format: Adobe PDF (.pdf), Microsoft PowerPoint-optimized (.pptx), PNG image (.png) or JPG image (.jpg, .jpeg). *Notes: If you choose Adobe…

Mauve alignment options

Perform a Multiple Alignment » Multiple alignment methods and options » Mauve alignment options

The Mauve alignment algorithm is for genome level alignment of nucleotide sequences. To run a Mauve alignment, select two or more nucleotide sequences and choose Align > (Re)Align Using Mauve. If you wish to change method options, instead choose Align > Align with…

Tracks panel

MegAlign Pro Interface » Panels » Tracks panel

The Tracks panel lets you manage the tracks displayed in the Overview and the Sequences view. To open the Tracks panel: Click on the Tracks tab (). If the panel is not already visible, reveal it using any of the following methods: Choose View > Tracks > Tracks…

Console panel

MegAlign Pro Interface » Panels » Console panel

The Console panel displays information, messages and warnings about the operation in progress, or an operation that was recently performed. To display the console for a particular project: Click the tab with the project name, then open its console using the View >…

Tracks

Tracks

“Tracks” are rows of information that can be displayed or hidden, as desired, in the Overview and Sequences view. Tracks can pertain to a header, footer, or individual sequence row. The following video provides a brief overview of how tracks are used in…

Overview after aligning multiple genomes with Mauve

MegAlign Pro Interface » Views » Overview » Overview after aligning multiple genomes with Mauve

The Overview has different appearances, depending on the stage and workflow. A Mauve genome alignment results in a set of locally colinear blocks (LCBs), each of which is a conserved region across multiple sequences. In MegAlign Pro, these may be referred to as…

Part B: Perform a Mauve alignment using modified parameters

Perform a Multiple Alignment » Try it! – Perform a genomic alignment with Mauve » Part B: Perform a Mauve alignment using modified parameters

In this part of the tutorial, you will explore how to view and change parameters prior to performing a multiple sequence alignment. Choose Align > Align Using Mauve and align the sequences using the default parameters. Because this is a genomic alignment, the…

Print Images

Print Images

To print an image of any MegAlign Pro view, whether it is currently active or not: Choose File > Print or use Ctrl/Cmd+P. The Print Document dialog opens: Use the Printer drop-down menu to choose the desired printer from a list of available…

Split and resize panes in a view

MegAlign Pro Interface » Views » Split and resize panes in a view

To change the relative sizes of panes: To change the sizes of panes (e.g., the sequence names and the alignment blocks areas in the Overview), drag the light gray divider bar between them to the left or right. The images below show examples in the Overview (left) and…

Multiple Alignment section

MegAlign Pro Interface » Panels » Style panel » Multiple Alignment section

To access options affecting the display of multiple alignments in the Sequences view, click on the Style panel expand bar entitled Multiple Alignment, or choose View > Style > Multiple Alignment. Use the Layout drop-down menu to specify the wrapping style for…

Perform a Pairwise Alignment

Perform a Pairwise Alignment

Pairwise alignments can only be performed when two sequences, and only two sequences, have been selected. A common workflow is to first perform a multiple alignment on an entire group of sequences. From the resulting Tree view, two closely related sequences can then…

Overview

MegAlign Pro Interface » Views » Overview

The Overview provides a way to navigate within the sequences, no matter what type of sequences or alignment is used. In the case of genomic alignments generated by Mauve, the Overview also allows you to explore the relationships between multiple aligned blocks.…

Perform an initial multiple alignment

Perform a Multiple Alignment » Perform an initial multiple alignment

To perform the initial multiple sequence alignment: Select two or more sequences to align. All sequences must belong to the same category (DNA/RNA or protein). Selected sequences can include any combination of already-aligned sequences and sequences in the…

MUSCLE alignment options

Perform a Multiple Alignment » Multiple alignment methods and options » MUSCLE alignment options

The MUSCLE algorithm is for gene level alignment of either protein or nucleotide sequences. To run a MUSCLE alignment, select two or more sequences and choose Align > (Re)Align Using MUSCLE. If you wish to change method options, instead choose Align > Align with…

Tree view

MegAlign Pro Interface » Views » Tree view

The Tree View shows evolutionary relationships estimated from the multiple sequence alignment, and is calculated using the currently selected Distance metric. The tree is built using the BioNJ algorithm (Gascuel, 1997), a variant of the Neighbor-Joining algorithm…

Map features (copy features to another sequence)

Features » Map features (copy features to another sequence)

MegAlign Pro’s feature mapping lets you map a single annotation, or all annotations from a source sequence, to a target sequence. The sequences involved must have been previously aligned. During the process, you may optionally filter annotations so as to…

Pairwise Alignment section

MegAlign Pro Interface » Panels » Style panel » Pairwise Alignment section

To access options affecting the display of pairwise alignments in the Pairwise view, click on the Style panel expand bar entitled Pairwise Alignment, or choose View > Style > Pairwise Alignment. Use the Layout drop-down menu to specify the wrapping style for…